Home Php C# Sql C C++ Javascript Python Java Go Android Git Linux Asp.net Django .net Node.js Ios Xcode Cocoa Iphone Mysql Tomcat Mongodb Bash Objective-c Scala Visual-studio Apache Elasticsearch Jar Eclipse Jquery Ruby-on-rails Ruby Rubygems Android-studio Spring Lua Sqlite Emacs Ubuntu Perl Docker Swift Amazon-web-services Svn Html Ajax Xml Java-ee Maven Intellij-idea Rvm Macos Unix Css Ipad Postgresql Css3 Json Windows-server Vue.js Typescript Oracle Hibernate Internet-explorer Github Tensorflow Laravel Symfony Redis Html5 Google-app-engine Nginx Firefox Sqlalchemy Lucene Erlang Flask Vim Solr Webview Facebook Zend-framework Virtualenv Nosql Ide Twitter Safari Flutter Bundle Phonegap Centos Sphinx Actionscript Tornado Register | Login | Edit Tags | New Questions | 繁体 | 简体


5 questions online user: 7

0
votes
answers
32 views
+10

npm安裝不安裝依賴關係 - 只是鎖定文件

0

我從來沒有任何問題npm install之前工作,所以我不確定現在的問題是什麼?npm安裝不安裝依賴關係 - 只是鎖定文件

我曾嘗試運行:

  • npm install
  • npm install --save-dev

我第一次讓我的IDE運行它(PHPStorm),它創造了node_modules文件夾,但沒有什麼是它的內部。

然後我刪除,並試圖手動運行它,但它所作的只是創建package-lock.json文件,並沒有別的,輸出功率爲:

npm notice created a lockfile as package-lock.json. You should commit this file. 
npm WARN Invalid version: "1.0" 
npm WARN www No description 
npm WARN www No repository field. 
npm WARN www No README data 
npm WARN www No license field. 

up to date in 0.087s 

現在和他們」之前,我已經有這些警告從未造成任何問題。

的package.json文件:

{ 
    "name": "**********", 
    "version": "1.0", 
    "main": "gulpfile.js", 
    "devDependencies": { 
    "autoprefixer": "^6.7.5", 
    "gulp": "^3.9.1", 
    "gulp-clean-css": "^2.0.13", 
    "gulp-concat": "^2.6.0", 
    "gulp-plumber": "^1.1.0", 
    "gulp-postcss": "^6.3.0", 
    "gulp-rename": "^1.2.2", 
    "gulp-sass": "^2.2.0", 
    "gulp-sourcemaps": "^1.6.0", 
    "gulp-uglify": "^2.0.0", 
    "gulp-util": "^3.0.7" 
    }, 
    "private": true 
} 

我然後跑npm install --save-dev --loglevel verbose這裏是輸出:

npm info it worked if it ends with ok 
npm verb cli [ 'C:\Program Files\nodejs\node.exe', 
npm verb cli 'C:\Users\Brett\AppData\Roaming\npm\node_modules\npm\bin\npm-cli.js', 
npm verb cli 'install', 
npm verb cli '--save-dev', 
npm verb cli '--loglevel', 
npm verb cli 'verbose' ] 
npm info using [email protected] 
npm info using [email protected] 
npm verb npm-session 24ddfff75bdd69e7 
npm verb correctMkdir C:UsersBrettAppDataRoaming
pm-cache\_locks correctMkdir not in flight; initializing 
npm verb lock using C:UsersBrettAppDataRoaming
pm-cache\_locksstaging-822c9c4b46ec75df.lock for D:******************
ode_modules.staging 
npm verb unlock done using C:UsersBrettAppDataRoaming
pm-cache\_locksstaging-822c9c4b46ec75df.lock for D:****************
ode_modules.staging 
npm info linkStuff !invalid#1 
npm verb linkBins !invalid#1 
npm verb linkMans !invalid#1 
npm info lifecycle undefined~install: undefined 
npm info lifecycle undefined~postinstall: undefined 
npm info lifecycle undefined~prepublish: undefined 
npm info lifecycle undefined~prepare: undefined 
npm verb saving [] 
npm verb shrinkwrap skipping write for package.json because there were no changes. 
npm info lifecycle undefined~preshrinkwrap: undefined 
npm info lifecycle undefined~shrinkwrap: undefined 
npm verb shrinkwrap skipping write for package-lock.json because there were no changes. 
npm info lifecycle undefined~postshrinkwrap: undefined 
npm WARN Invalid version: "1.0" 
npm WARN www No description 
npm WARN www No repository field. 
npm WARN www No README data 
npm WARN www No license field. 

up to date in 0.057s 
npm verb exit [ 0, true ] 
npm info ok 

問題是什麼嗎?

沙发
0
0

好吧,看起來,即使它只是一個WARN,這個問題是version.

我所要做的就是從1.0更改爲1.0.0,並開始工作。

0
votes
answers
70 views
+10

試圖使用papaparse vue

0

我想用papaparse來解析一個csv文件與vue,但我遇到安裝麻煩。我使用npm來安裝papaparse,並使用以下命令: npm install papaparse 但是,npm給了我這些警告: WARN [email protected] requires a peer of [email protected]^3.3.7 but none was installed.WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})。從這裏,我認爲它需要我使用bootstrap,但在papaparse上,它聲明它不需要任何依賴關係?我如何正確安裝papaparse,以便我可以在我的vue項目中使用它?試圖使用papaparse vue

+1

您是否安裝了其他軟件包?您可能會在問題頁面https://github.com/mholt/PapaParse/issues上提問更好的問題。 –

+0

您可以忽略第二個警告。 fsevents包沒有安裝,因爲只適用於MacOS(https://github.com/npm/npm/issues/12497)。 – yuriy636

沙发
0
0

我只加了papaparse.min.js文件到我的web項目,並添加到bundleConfig,編譯和

Papa.parse 

立即工作。

只需注意保存文件的路線。

0
votes
answers
66 views
+10

流星 - 無法使用/進口NPM包

0

我不能做:流星 - 無法使用/進口NPM包

import SimpleSchema from 'simpl-schema'; 

或導入任何其他NPM包使用此命令。我已經通過meteor npm install --save simpl-schema安裝了該軟件包。

我也試圖引入其他NPM的依賴關係,如:

import moment from 'moment'; 

因此,我認爲,我通常錯過了一些重要的是能夠爲需要NPM包在我的客戶端代碼或我使用錯誤的結構?

我得到的錯誤:

Uncaught SyntaxError: Unexpected identifier

在瀏覽器控制檯。 我將不勝感激任何幫助,謝謝!

編輯:

我已經在運行應用程序之前調用meteor npm install

如果我的代碼在服務器端的js文件這一行import moment from 'moment';,我得到以下錯誤:

appserverstartupprofilemanagement.js:1 (function(NPM,Assets){(function(){import moment from 'moment';

SyntaxError: Unexpected token import at C:...meteorlocaluildprogramsserveroot.js:392:18 at Array.forEach() at Function..each..forEach (C:...meteorpackagesmeteor-tool1.6.0:1mt-os.windows.x86_64dev_bundleserver-lib ode_modulesunderscoreunderscore.js:79:11) at C:...meteorlocaluildprogramsserveroot.js:220:5 at C:...meteorlocaluildprogramsserveroot.js:463:5 at Function.run (C:...meteorlocaluildprogramsserverprofile.js:510:12) at C:...meteorlocaluildprogramsserveroot.js:462:11

我不知道我是否安裝了巴貝爾包correcty。我認爲那裏出了問題。這是我的package.json:

{ 
    "dependencies": { 
    "abbrev": "^1.1.0", 
    "addressparser": "^1.0.1", 
    "ajv": "^5.2.2", 
    "ansi-regex": "^3.0.0", 
    "aproba": "^1.2.0", 
    "are-we-there-yet": "^1.1.4", 
    "asn1": "^0.2.3", 
    "assert-plus": "^1.0.0", 
    "asynckit": "^0.4.0", 
    "aws-sign2": "^0.7.0", 
    "aws4": "^1.6.0", 
    "babel-runtime": "^6.26.0", 
    "balanced-match": "^1.0.0", 
    "bcrypt": "^1.0.3", 
    "bcrypt-pbkdf": "^1.0.1", 
    "block-stream": "0.0.9", 
    "boom": "^5.2.0", 
    "brace-expansion": "^1.1.8", 
    "buildmail": "^4.0.1", 
    "caseless": "^0.12.0", 
    "chart.js": "^2.7.0", 
    "chartjs-color": "^2.2.0", 
    "cloudinary": "^1.9.0", 
    "co": "^4.6.0", 
    "code-point-at": "^1.1.0", 
    "color-convert": "^1.9.0", 
    "color-name": "^1.1.3", 
    "combined-stream": "^1.0.5", 
    "concat-map": "0.0.1", 
    "console-control-strings": "^1.1.0", 
    "core-js": "^2.5.1", 
    "core-util-is": "^1.0.2", 
    "cryptiles": "^3.1.2", 
    "dashdash": "^1.14.1", 
    "debug": "^3.0.1", 
    "deep-extend": "^0.5.0", 
    "delayed-stream": "^1.0.0", 
    "delegates": "^1.0.0", 
    "ecc-jsbn": "^0.1.1", 
    "extend": "^3.0.1", 
    "extsprintf": "^1.3.0", 
    "fast-deep-equal": "^1.0.0", 
    "fontawesome": "^4.7.2", 
    "forever-agent": "^0.6.1", 
    "form-data": "^2.3.1", 
    "fs.realpath": "^1.0.0", 
    "fstream": "^1.0.11", 
    "fstream-ignore": "^1.0.5", 
    "gauge": "^2.7.4", 
    "getpass": "^0.1.7", 
    "glob": "^7.1.2", 
    "graceful-fs": "^4.1.11", 
    "har-schema": "^2.0.0", 
    "har-validator": "^5.0.3", 
    "has-unicode": "^2.0.1", 
    "hawk": "^6.0.2", 
    "hoek": "^4.2.0", 
    "http-signature": "^1.2.0", 
    "iconv-lite": "^0.4.19", 
    "inflight": "^1.0.6", 
    "inherits": "^2.0.3", 
    "ini": "^1.3.4", 
    "is-fullwidth-code-point": "^2.0.0", 
    "is-typedarray": "^1.0.0", 
    "isarray": "^2.0.2", 
    "isstream": "^0.1.2", 
    "jasny-bootstrap": "^3.1.3", 
    "jodid25519": "^1.0.2", 
    "jsbn": "^1.1.0", 
    "json-schema": "^0.2.3", 
    "json-schema-traverse": "^0.3.1", 
    "json-stable-stringify": "^1.0.1", 
    "json-stringify-safe": "^5.0.1", 
    "jsonify": "0.0.0", 
    "jsprim": "^1.4.1", 
    "libbase64": "^0.2.0", 
    "libmime": "^3.1.0", 
    "libqp": "^1.1.0", 
    "lodash": "^4.17.4", 
    "mailcomposer": "^4.0.2", 
    "meteor-node-stubs": "^0.2.11", 
    "mime-db": "^1.30.0", 
    "mime-types": "^2.1.17", 
    "minimatch": "^3.0.4", 
    "minimist": "^1.2.0", 
    "mkdirp": "^0.5.1", 
    "moment": "^2.18.1", 
    "ms": "^2.0.0", 
    "nan": "^2.7.0", 
    "node-pre-gyp": "^0.6.37", 
    "nodemailer": "^4.1.0", 
    "nodemailer-fetch": "^2.1.0", 
    "nodemailer-shared": "^2.0.0", 
    "nopt": "^4.0.1", 
    "npmlog": "^4.1.2", 
    "number-is-nan": "^1.0.1", 
    "oauth-sign": "^0.8.2", 
    "object-assign": "^4.1.1", 
    "object-inspect": "^1.3.0", 
    "object-keys": "^1.0.11", 
    "once": "^1.4.0", 
    "os-homedir": "^1.0.2", 
    "os-tmpdir": "^1.0.2", 
    "osenv": "^0.1.4", 
    "path-is-absolute": "^1.0.1", 
    "path-parse": "^1.0.5", 
    "performance-now": "^2.1.0", 
    "process-nextick-args": "^1.0.7", 
    "punycode": "^2.1.0", 
    "q": "^1.5.0", 
    "qs": "^6.5.1", 
    "rc": "^1.2.1", 
    "readable-stream": "^2.3.3", 
    "regenerator-runtime": "^0.11.0", 
    "request": "^2.82.0", 
    "resolve": "^1.4.0", 
    "resumer": "0.0.0", 
    "rimraf": "^2.6.2", 
    "safe-buffer": "^5.1.1", 
    "semver": "^5.4.1", 
    "set-blocking": "^2.0.0", 
    "signal-exit": "^3.0.2", 
    "sntp": "^2.0.2", 
    "sshpk": "^1.13.1", 
    "string-width": "^2.1.1", 
    "string.prototype.trim": "^1.1.2", 
    "string_decoder": "^1.0.3", 
    "stringstream": "0.0.5", 
    "strip-ansi": "^4.0.0", 
    "strip-json-comments": "^2.0.1", 
    "sweetalert": "^1.1.3", 
    "tape": "^4.8.0", 
    "tar": "^4.0.1", 
    "tar-pack": "^3.4.0", 
    "through": "^2.3.8", 
    "tough-cookie": "^2.3.2", 
    "tunnel-agent": "^0.6.0", 
    "tweetnacl": "^1.0.0", 
    "uid-number": "0.0.6", 
    "util-deprecate": "^1.0.2", 
    "uuid": "^3.1.0", 
    "verror": "^1.10.0", 
    "wide-align": "^1.1.2", 
    "wow.js": "^1.2.2", 
    "wrappy": "^1.0.2", 
    "yallist": "^3.0.2" 
    } 
} 

第二個編輯:(?也許自上次更新)

好吧,這似乎是我有流星安裝和新公共管理的重大課題依賴。我不能夠創建一個新的流星項目因這個錯誤:

Error: Error: Could not install npm dependencies for test-packages: Command failed: C:WINDOWSsystem32cmd.exe /c C:Users...AppDataLocal.meteorpackagesmeteor-tool1.6.0._1mt-os.windows.x86_64dev_bundlein pm.cmd install npm ERR! code ENOGIT npm ERR! No git binary found in $PATH npm ERR! npm ERR! Failed using git. npm ERR! Please check if you have git installed and in your PATH.

你可以在這裏檢查這個錯誤: https://github.com/meteor/meteor/issues/8585。它告訴我,由於沒有找到Git路徑,所以不能安裝Npm依賴項。

但是,重新安裝Git的解決方案並不適合我。所以,我認爲自上次流星更新以來,一般情況都是錯誤的......我現在有點卡住了。也許唯一的解決辦法是重新安裝流星或使用舊版本?我從我的電腦開始使用舊流星版本的這個項目,卸載並重新安裝babel沒有任何區別。

+0

錯誤似乎與代碼中的不同位置有關(語法錯誤),有沒有關於行,類錯誤堆棧等的任何信息? – Jankapunkt

+0

感謝您的回覆。不幸的是,我沒有任何有關特定行或任何其他信息,而不是事實,即只有在我的客戶端代碼中包含「import ...」行時纔會發生此錯誤。當我點擊chrome中的「sources」時,我可以看到'(函數(){'{''simpl-schema'; ...')將該SimpleSchema從紅色高亮顯示出來,所以它告訴我這個錯誤是因爲那麼這段代碼是否正確,或者我是否可能需要使用另一種語法或「簡單模式」路徑? – Jaybruh

+1

對此有一些想法1.您是否在運行應用程序之前調用了'meteor npm install'?這個錯誤是否也發生在服務器端?如果是這樣,請從服務器控制檯發佈錯誤堆棧。3.你確定Babel包安裝正確嗎?請發佈你的package.json – Jankapunkt

沙发
0
0

好的,明白了!儘管我不清楚導致錯誤的原因,但我可以通過創建一個帶有--bare標誌的新流星項目來解決這個問題(所以現在我知道所有的npm依賴項都已正確安裝,以確保我可以使用'import')並複製了我的代碼到項目中。然而,比我得到另一個錯誤消息,告訴我,我的引導程序與我的jQuery版本不兼容。解決此之前,我曾在我的client/vendor文件夾,這會產生另一個錯誤

Uncaught Error: Cannot find module ‘…/…/lib/codemirror’

比我安裝刪除codemirror[email protected]再加上我在我的代碼使用所有必要的數據表NPM的依賴,以保持我的應用引導和jQuery的兼容性。現在我可以使用import SimpleSchema from 'simpl-schema'和所有其他導入,並且不會再出現錯誤。

最後,一些npm和/或包是錯誤的,最初的錯誤可以通過創建一個新的流星項目來解決。其他錯誤與bootstrap/jquery兼容性和codemirror相關。

0
votes
answers
62 views
+10

權限被拒絕npm install的錯誤

0

剛剛重新安裝了我的ubuntu,並且安裝了必要的東西,如nodejs npm。如果我克隆項目,並試圖sudo npm install我得到了這個錯誤。有人有同樣的問題?權限被拒絕npm install的錯誤

使用 節點:8.9.3 NPM:5.5.1

fetchPackageMetaData error for [email protected]://github.com/gulpjs/gulp.git#4ed9a4a3275559c73a396eff7e1fde3824951ebb Command failed: /usr/bin/git clone -q git://github.com/gulpjs/gulp.git /home/user_name/.npm/_cacache/tmp/git-clone-0e191fc9 

fetchPackageMetaData /home/user_name/.npm/_cacache/tmp/git-clone-0e191fc9/.git: Permission denied 

Error: Command failed: /usr/bin/git clone -q git://github.com/gulpjs/gulp.git /home/user_name/.npm/_cacache/tmp/git-clone-0e191fc9 

/home/user_name/.npm/_cacache/tmp/git-clone-0e191fc9/.git: Permission denied 
+0

https://stackoverflow.com/questions/31744852/npm-install-giving-error-while-accessing-git-url這個問題可能有幫助。 – evolutionxbox

+0

npm與安裝節點一起安裝...我避免使用sudo ...如果使用sudo安裝節點,則所有npm install命令也必須發出sudo ...如果您在安裝過程中避免使用sudo,請不要使用'sudo npm安裝x' ...安裝沒有sudo可以是原始代碼安裝或編譯安裝...閱讀內嵌評論 https://askubuntu.com/questions/426750/how-can-i-update-my -nodejs到了,最新版本/ 959382#959382 –

沙发
0
0

安裝節點沒有sudo和你不會得到拒絕 「權限錯誤」。

sudo npm install node

使用此命令:

npm install node

22
votes
answers
34 views
+10

為什麼“npm install”重寫package-lock.json?

我剛剛升級到npm @ 5。我現在有一個package-lock.json文件,其中包含package.json中的所有內容。我希望,當我運行 npm install 時,將從鎖定文件中提取依賴版本以確定應該在我的node_modules目錄中安裝什麼。奇怪的是它實際上最終修改並重寫了我的package-lock.json文件。

例如,鎖定文件的typescript指定為版本2.1.6。然後,在 npm install 命令之後,版本更改為2.4.1。這似乎打敗了鎖定文件的整個目的。

我錯過了什麼?如何讓npm真正尊重我的鎖文件?

沙发
+70

使用 npm ci 命令代替 npm install

“ci”代表“clean install”。它將基於package-lock.json文件而不是lenient package.json文件依賴項來安裝項目依賴項。

它將為您的其他團隊成員生成相同的構建,並且速度也快得多。< / p>

ci指的是“持續集成”,如文檔和博客文章中所述,宣布該命令:blog.npmjs.org/post/171556855892/ - Joe Atzberger Jun 13 at 1:04

板凳
+60

你的 package.json中可能有類似的東西:

 “typescript”:“~2.1.6”  

代碼>哪個npm更新到最新的次要版本,在你的情況下是 2.4.1

編輯:來自OP的問題

但是沒有解釋為什麼“npm install”會改變鎖定文件。鎖文件不是要創建可重現的構建嗎?如果是這樣,無論semver值如何,它仍應使用相同的2.1.6版本。

答案:

這是為了鎖定完整的依賴關係樹。假設 typescript v2.4.1 需要 widget~v1.0.0 當您安裝npm時,它會抓取 widget v1.0.0 稍後您的開發人員(或CI構建)執行npm安裝並獲取 typescript v2.4.1 ,但 widget 已更新為 widget v1.0.1 現在您的節點模塊不同步。這就是 package-lock.json 阻止的。

或更一般地說:

例如,考慮

包A:

{“name”:“A”,“version”:“0.1.0”,“依賴”:{“B”:“&lt; 0.1.0”}}

包B:

{“name”:“B”,“version”:“0.0.1”,“dependencies”:{“C”:“&lt; 0.1.0”}}

和包C:

{“name”:“C”,“version”:“ 0.0.1“}

如果這些是註冊表中唯一的A,B和C版本,那麼將安裝正常的npm安裝A:

A@0.1。 0 - B@0.0.1 - C@0.0.1

但是,如果發布了B@0.0.2,那麼將安裝新的npm安裝A:

A @ 0.1.0 - B@0.0.2 - C@0.0.1假設新版本沒有修改B的依賴關係。當然,新版本的B可能包含新版本的C和任意數量的新依賴項。如果不希望這樣的改變,A的作者可以指定對B@0.0.1的依賴。但是,如果A的作者和B的作者不是同一個人,那麼A的作者就沒有辦法說當B完全沒有改變時他或她不想引入新出版的C版本。


OP問題2:讓我看看我是否理解正確。您所說的是鎖文件指定了輔助依賴項的版本,但仍然依賴於package.json的模糊匹配來確定頂級依賴項。這是否準確?

答案:否.package-lock鎖定整個包樹,包括 package.json 中描述的根包。如果 typescript package-lock中的 2.4.1 處被鎖定。json ,它應該保持這種狀態,直到它被改變。讓我們說明天 typescript 發布版本 2.4.2 如果我簽出你的分支並運行 npm install ,npm將尊重lockfile並安裝 2.4.1

更多關於 package-lock.json

自動為npm修改node_modules樹或package.json的任何操作生成package-lock.json。它描述了生成的確切樹,以便後續安裝能夠生成相同的樹,而不管中間依賴性更新。

此文件旨在提交到源存儲庫中,並用於各種目的: / p> <

但這並不能解釋為什麼“npm install”會改變鎖定文件。鎖文件不是要創建可重現的構建嗎?如果是這樣,無論semver值如何,它仍應使用相同的2.1.6版本。 - Viper Bailey 17年7月10日21:53

這就是我說的話。我的包鎖文件說typescript@2.1.6但是當我運行npm install時,該條目被替換為typescript@2.4.1。 - Viper Bailey 17年7月11日16:56

我遇到過同樣的問題。在我們的CI / CD中,package-lock.json被拉下來,然後我們運行npm install,但是package-lock.json文件被修改了,我們必須先執行重置,然後再進行下一次更改。 - BayssMekanique 17年7月24日19:42

我不明白。如果後續安裝可能仍然進行升級,這是一個“鎖定”文件怎麼樣?! - 羅斯艾倫2017年8月4日17:17

我認為他們開始時想把這個文件作為“信息”和“鎖定”,然後決定它只是一個“信息”文件。更好的名字是“package-info.json”。我很想有一個“npm install -lock”,它將從“package-lock.json”安裝並忽略“package.json” - Jeremy Chone於2017年9月7日凌晨2點20分

地板
+50

將來,您將能夠使用 - from-lock-file (或類似)標誌從包中安裝 only - lock.json 而不修改它。

這對於可重複構建很重要的CI等環境非常有用。

參見 https://github.com/npm/npm/issues/18286

我對此表示懷疑。如果不同操作系統的依賴關係如何不同,你如何強制安裝不起作用的東西? - Yevgeniy Afanasyev 18年1月24日23:27

@YevgeniyAfanasyev而不是那個標誌,它被實現為npm ci,它也處理你的問題。 - spex '18年3月30日2:45

5楼
+10

在他們的github頁面上存在一個未解決的問題: https://github.com / npm / npm / issues / 18712

當開發人員使用不同的操作系統時,此問題最嚴重。

包鎖的重寫是有意的,問題不是這個問題的結果 - Z. Khullah 18年7月20日2:54

6楼
0
編輯:名稱“鎖定”是一個棘手的,它的NPM試圖趕上紗線。它不是一個鎖定的文件。 package.json 是一個用戶修復的文件,一旦“安裝”將生成node_modules文件夾樹,然後該樹將被寫入 package-lock.json 所以你看,它的另一種方式 - 依賴版本將一如既往地從 package.json 中提取,而 package-lock.json 應該被稱為 package- tree.json

(希望這可以讓我的答案更清楚,經過這麼多的downvotes)


一個簡單的答案: package.json 像往常一樣擁有依賴關係,而 package-lock.json 是“確切的,

為什麼投票? - Z. Khullah 18年1月25日12:16

因為如果運行npm install,將更新package-lock。 - Jean-Baptiste 18年2月19日16:34